用户:Admin

来自Jabber/XMPP中文翻译计划
2009年4月6日 (一) 05:03Admin (讨论 | 贡献)的版本
(差异) ←上一版本 | 最后版本 (差异) | 下一版本→ (差异)
跳转到: 导航, 搜索

最近的OPENFIRE3.6.3支持了LDAP,但是有两个限制:

  1. 安装的时候要选择内部数据库,就是hsql数据库。
  2. OPENFIRE对于LDAP是只读的,也就是说无法注册用户。

解决的办法是:

  1. 把LdapUserProvider.java的isReadOnly只读特性改为false, 然后把其中欠缺的createUser,deleteUser,setName,setEmail方法补充完整,实现用户的新增,删除,修改昵称和邮箱。
  2. 把LdapAuthProvider.java欠缺的setPassword补充完整,实现修改密码。
  3. 其他。。。待续
个人工具
粤ICP备13086730号-4